JQuery a changé la vie de pas mal de développeurs web...
JQuery a changé la vie de pas mal de développeurs web...

Optimiser WordPress en utilisant JSDelivr & Google Library pour Jquery !

Hello à tous !

Petite découverte du jour : Une des raisons de la lenteur de chargement des WordPress, c’est l’utilisation abusive de Javascript… Et je suis pleinement dans ce cas ! Mais sachez que si vous utilisez des ressources de CDN officiels, il y a de fortes chances que votre internaute ait déjà chargé ces librairies dans son navigateur… Et cela vous économisera quelques millisecondes de chargement !

Pour cela, il existait un plugin (Use Google Libraries), mais celui ci ne fonctionne plus avec les nouvelles versions de WordPress. En plus il n’est plus mis à jour… Moi je vous propose une solution simple : Utiliser le fichier function.php de votre thème et… Roulez jeunesse ! Ajoutez-y ces instructions :

////////////////////////////////////////////////////////////////////////
// On utilise les cdn Google et JSdelivr 🙂 ////////////////////////////
////////////////////////////////////////////////////////////////////////
function register_jquery() {
if (!is_admin()) {
wp_deregister_script(‘jquery-core’);
wp_register_script(‘jquery-core’, ‘https://ajax.googleapis.com/ajax/libs/jquery/2.2.0/jquery.min.js’, true, ‘2.2.0’);
wp_enqueue_script(‘jquery-core’);
wp_deregister_script(‘jquery-migrate’);
wp_register_script(‘jquery-migrate’, ‘https://cdn.jsdelivr.net/jquery.migrate/1.2.1/jquery-migrate.min.js’, true, ‘1.2.1’);
wp_enqueue_script(‘jquery-migrate’);
wp_deregister_script(‘jquery-ui’);
wp_register_script(‘jquery-ui’, ‘https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/jquery-ui.min.js’, true, ‘1.11.4’);
wp_enqueue_script(‘jquery-ui’);
}
}
add_action( ‘wp_enqueue_scripts’, ‘register_jquery’ );

Et voilà ! Les principales ressources javascript de votre wordpress seront gérées depuis des CDN 😉 ! Elle est pas belle la vie ? Notez également que wordpress vous propose un CDN image gratuit, photon, livré avec le plugin Jetpack, que je ne peux que vous conseiller d’activer pour encore soulager votre serveur !

Ah oui, petit détail : ma version de jQuery, la 2.2.0, cassera la compatibilité avec les navigateurs Internet Explorer plus vieux que IE9… Mais c’est un choix qui m’est personnel, puisque j’améliore l’expérience sur mobile, tablette et ordinateurs modernes en contrepartie 😉 !

SuzuKube
Webmaster d'Otakugame.fr, je tente ici de vous montrer ma "vie de blogueur" et de "développeur web" !

1 Response

Laisser un commentaire